Devices with Bluetooth 4.0 or above, and iOS8.0 or above

Leave a Reply

Your email address will not be published.